Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Idempotency can be achieved using the configuration version.  More information can be found here Upgrade rule filtering based on version.

Code Block
languagebash
themeEmacs
titleIdempotency using configuration version
def UPGRADE_TO_VERSION = "1.0.0.1"    
def APPLICABLE_VERSIONS = ["1.1.0.0","2.0.0.0"]
return
    [
    setVersion(UPGRADE_TO_VERSION),
    forRealmService("authenticationTreesService",
       forVersionsBefore(APPLICABLE_VERSIONS,
           forRealmDefaults(
               addAttribute("new").with("attribute"))
            )
       )
    ]

...